specchio di Kafka non iniziano

im nel processo di aggiornamento del nostro cluster. tuttavia Im avendo problemi cercando di rendere le mirrormakers eseguire.

quindi queste macchine hanno kafka-brokers e kafka-mirrormakers in esecuzione. hanno script init separati.

i broker attualmente utilizzano la versione 10.1.1.1 e mirrormakers utilizzano la versione 0.8.2-beta.

entrambi hanno i propri file di configurazione e posizioni

per esempio i broker sono installati in / server / kafka / mirrormakers sono installati sotto / opt / kafka _ mirrormaker.

qui le linee di configurazione per i broker seguendo ciò che il processo di aggiornamento ha spiegato:

inter.broker.protocol.version=0.10.1
log.message.format.version=0.8.2

e per gli speculatori:

inter.broker.protocol.version=0.8.2
log.message.format.version=0.8.2

così stavo testando per aggiornare questo alla 10.2.1 ho provato l’aggiornamento in un unico host. broker funziona bene dopo che ho applicato l’aggiornamento versione 10.2.1 tuttavia lo mirrormaker muore subito quando ho cercato di avviarlo.

vedo questa eccezione sui registri

    Exception in thread "main" java.lang.NullPointerException
    at kafka.tools.MirrorMaker$.main(MirrorMaker.scala:309)
    at kafka.tools.MirrorMaker.main(MirrorMaker.scala)
Exception in thread "MirrorMakerShutdownHook" java.lang.NullPointerException
    at kafka.tools.MirrorMaker$.cleanShutdown(MirrorMaker.scala:399)
    at kafka.tools.MirrorMaker$$anon$2.run(MirrorMaker.scala:222)
tail: kafka-mirrormaker-repl-sjc2-to-hkg1.out: file truncated
Exception in thread "main" java.lang.NullPointerException
    at kafka.tools.MirrorMaker$.main(MirrorMaker.scala:309)
    at kafka.tools.MirrorMaker.main(MirrorMaker.scala)
Exception in thread "MirrorMakerShutdownHook" java.lang.NullPointerException
    at kafka.tools.MirrorMaker$.cleanShutdown(MirrorMaker.scala:399)
    at kafka.tools.MirrorMaker$$anon$2.run(MirrorMaker.scala:222)

e questo e questo

[2017-05-18 17:02:27,936] ERROR Exception when starting mirror maker. (kafka.tools.MirrorMaker$)
org.apache.kafka.common.config.ConfigException: Missing required configuration "bootstrap.servers" which has no default value.
    at org.apache.kafka.common.config.ConfigDef.parse(ConfigDef.java:436)
    at org.apache.kafka.common.config.AbstractConfig.<init>(AbstractConfig.java:56)
    at org.apache.kafka.common.config.AbstractConfig.<init>(AbstractConfig.java:63)
    at org.apache.kafka.clients.producer.ProducerConfig.<init>(ProducerConfig.java:340)
    at org.apache.kafka.clients.producer.KafkaProducer.<init>(KafkaProducer.java:191)
    at kafka.tools.MirrorMaker$MirrorMakerProducer.<init>(MirrorMaker.scala:694)
    at kafka.tools.MirrorMaker$.main(MirrorMaker.scala:236)
    at kafka.tools.MirrorMaker.main(MirrorMaker.scala)

questo errore di bootstrap è strano a causa di questo già config. il server.properties ha localhost: 9292 configurato come bootstrap.server

per aggiornare questo ho fatto broker e mirrormaker allo stesso tempo. im non è sicuro se devo prima aggiornare tutti i broker prima e poi i mirrormakers.

eventuali suggerimenti. se dovessi seguire la stessa procedura, aggiornare prima tutti i broker e poi tutti mirrormakers. una volta che sono aggiornamento bump i protocolli in server.properties. anche se quando sembra che il tipo di documentazione non implica che: http://kafka.apache.org/documentation.html#upgrade

EN From: Kafka mirrormaker do not start

More similar articles:

1 Comment

  1. questo è stato risolto. il motivo per cui non stavano iniziando era dovuto alle opzioni sui file di configurazione cambiare o non erano correttamente configurare

Leave a Reply

Your email address will not be published. Required fields are marked *